Installation

  1. Go to Settings or Preferences|Plugins. Select Marketplace tab and search for “Elasticsearch”: Image

  2. Select “Elasticsearch” plugin and click the Install button.

  3. When installation is finished, click the Restart IDE button.

Prerequisites

IntelliJ Elasticsearch runs on the IntelliJ platform and requires one of JetBrains IDEs. The currently supported IDEs are:

  • IntelliJ IDEA Ultimate — 2020.3+
  • IntelliJ IDEA Community — 2020.3+ (FREE)
  • IntelliJ IDEA Educational — 2020.3+
  • WebStorm — 2020.3+
  • Android Studio — build 2020.3+ (FREE)
  • PhpStorm — 2020.3+
  • PyCharm Professional — 2020.3+
  • PyCharm Community — 2020.3+ (FREE)
  • PyCharm Educational — 2020.3+
  • RubyMine — 2020.3+
  • DataGrip — 2020.3+
  • GoLand — 2020.3+
  • AppCode — 2020.3+
  • Rider — 2020.3+
  • CLion — 2020.3+
  • MPS — 2020.3+
  • DataSpell — 2021.3 (eap)+